Quantcast

CodeStriker Configuration Issues with IIS 5.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

CodeStriker Configuration Issues with IIS 5.1

Hari Krishna Duvuri

Hello All,

 

I have followed the configuration of CodeStriker as specified in “Codestriker Guide” but the below is the issues

 

I am deploying on “Windows XP with SP 3” and “IIS 5.1”.

 

As specified in section 2.5 I have configured and when I try to browse the http://localhost/codestriker/codestriker.pl and it throws and error page couldn’t be found. I further went and checked in “D:\codestriker\bin” but I didn’t find the “codestriker.pl” file.

 

Further to test the configuration is correct or not I have created a sample .pl file and followed the below steps and it worked fine. I hope the problem is creating the virtual directory and point to right file as specified in section 2.5.

 

Pls let me know if anyone had faced this issues and addressed it.

 

2.5. IIS configuration

Startup the IIS configuration application by going to "Control Panel" -> "Administrative Tools" -> "Internet Services Manager". Like the Apache configuration, the webserver needs to be told where to find the Codestriker CGI script, and where to find the associated CSS and html help files. Assuming you are deploying Codestriker under the "Default Web site", right-click this entry on the left hand frame of the window, and select "New" -> "Virtual Directory" -> "Next". Enter in codestriker into the Alias

textfield, then click "Next". Then enter the cgi-bin directory of your unpacked Codestriker distribution into the "Directory" textfield, then click "Next". Make sure the "Execute" access permission checkbox is selected, then click "Next", click then "Finished".

 

It is important that the codestriker virtual directory is setup to be able to execute Perl scripts. Right-click the codestriker virtual directory and select "Properties". Click on the "Configuration..." button. Check that there is an entry for .pl files, and that the "Executable Path" entry looks like (substitute the path to your local Perl installation):

 

C:\Perl\bin\perl.exe "%s" %s

 

If there is no mapping for .pl files (which would be odd, since the ActiveState install does this for you automatically), add a new entry in with the above setting, limited to "GET,HEAD,POST". Make sure you enter the quotes, as shown above. Follow a similar process for the codestrikerhtml directory. Right-click "Default Web site" and select "New" -> "Virtual Directory" -> "Next". Enter in codestrikerhtml into the Alias textfield, then click "Next". Then enter the html directory of your unpacked Codestriker distribution into the "Directory" textfield, then click "Next". Make sure the "Read" and "Browse" access permission checkboxes are selected, then "Next", then "Finished".

 

Best Regards,

Hari Krishna Duvuri

 


Think green - keep it on the screen. This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.
------------------------------------------------------------------------------
Simplify data backup and recovery for your virtual environment with vRanger.
Installation's a snap, and flexible recovery options mean your data is safe,
secure and there when you need it. Discover what all the cheering's about.
Get your free trial download today.
http://p.sf.net/sfu/quest-dev2dev2 
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CodeStriker Configuration Issues with IIS 5.1

David Sitsky
Administrator
> As specified in section 2.5 I have configured and when I try to browse the
> http://localhost/codestriker/codestriker.pl and it throws and error page
> couldn’t be found. I further went and checked in “D:\codestriker\bin” but I
> didn’t find the “codestriker.pl” file.

You need to run the install.pl script which will auto-generate the
codestriker.pl file for you.

Cheers,
David

------------------------------------------------------------------------------
Simplify data backup and recovery for your virtual environment with vRanger.
Installation's a snap, and flexible recovery options mean your data is safe,
secure and there when you need it. Discover what all the cheering's about.
Get your free trial download today.
http://p.sf.net/sfu/quest-dev2dev2 
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CodeStriker Configuration Issues with IIS 5.1

Hari Krishna Duvuri
David,

I am getting the following error when i run the "install.pl" file
command prompt. I hope I am still missing some settings

String found where operator expected at
D:\codestriker/lib/Codestriker.pm line 5
69, near "croak "Failed to execute $system_line: $!\n""
        (Do you need to predeclare croak?)
syntax error at D:\codestriker/lib/Codestriker.pm line 569, near "croak
"Failed
to execute $system_line: $!\n""
Compilation failed in require at
D:\codestriker/lib/Codestriker/DB/DBI.pm line 1
4.
BEGIN failed--compilation aborted at
D:\codestriker/lib/Codestriker/DB/DBI.pm li
ne 14.
Compilation failed in require at
D:\codestriker/lib/Codestriker/Model/User.pm li
ne 14.
BEGIN failed--compilation aborted at
D:\codestriker/lib/Codestriker/Model/User.p
m line 14.
Compilation failed in require at D:\codestriker\bin\install.pl line 58.
BEGIN failed--compilation aborted at D:\codestriker\bin\install.pl line
58.

Best Regards,
Hari Krishna D

-----Original Message-----
From: David Sitsky [mailto:[hidden email]]
Sent: Tuesday, June 07, 2011 1:02 AM
To: Duvuri, Hari Krishna
Cc: [hidden email]
Subject: Re: [Codestriker-user] CodeStriker Configuration Issues with
IIS 5.1

> As specified in section 2.5 I have configured and when I try to browse

> the http://localhost/codestriker/codestriker.pl and it throws and
> error page couldn't be found. I further went and checked in
> "D:\codestriker\bin" but I didn't find the "codestriker.pl" file.

You need to run the install.pl script which will auto-generate the
codestriker.pl file for you.

Cheers,
David


Think green - keep it on the screen.

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.



------------------------------------------------------------------------------
EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
http://p.sf.net/sfu/ephox-dev2dev
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CodeStriker Configuration Issues with IIS 5.1

David Sitsky
Administrator
You really need to use Perl 5.8 or 5.10.  The Perl people changed the
list of default packages installed.

You can still use 5.12, but edit the Codestriker.pm file and replace
all instances of "croak" with "die".

On Tue, Jun 7, 2011 at 1:35 PM, Duvuri, Hari Krishna
<[hidden email]> wrote:

> David,
>
> I am getting the following error when i run the "install.pl" file
> command prompt. I hope I am still missing some settings
>
> String found where operator expected at
> D:\codestriker/lib/Codestriker.pm line 5
> 69, near "croak "Failed to execute $system_line: $!\n""
>        (Do you need to predeclare croak?)
> syntax error at D:\codestriker/lib/Codestriker.pm line 569, near "croak
> "Failed
> to execute $system_line: $!\n""
> Compilation failed in require at
> D:\codestriker/lib/Codestriker/DB/DBI.pm line 1
> 4.
> BEGIN failed--compilation aborted at
> D:\codestriker/lib/Codestriker/DB/DBI.pm li
> ne 14.
> Compilation failed in require at
> D:\codestriker/lib/Codestriker/Model/User.pm li
> ne 14.
> BEGIN failed--compilation aborted at
> D:\codestriker/lib/Codestriker/Model/User.p
> m line 14.
> Compilation failed in require at D:\codestriker\bin\install.pl line 58.
> BEGIN failed--compilation aborted at D:\codestriker\bin\install.pl line
> 58.
>
> Best Regards,
> Hari Krishna D
>
> -----Original Message-----
> From: David Sitsky [mailto:[hidden email]]
> Sent: Tuesday, June 07, 2011 1:02 AM
> To: Duvuri, Hari Krishna
> Cc: [hidden email]
> Subject: Re: [Codestriker-user] CodeStriker Configuration Issues with
> IIS 5.1
>
>> As specified in section 2.5 I have configured and when I try to browse
>
>> the http://localhost/codestriker/codestriker.pl and it throws and
>> error page couldn't be found. I further went and checked in
>> "D:\codestriker\bin" but I didn't find the "codestriker.pl" file.
>
> You need to run the install.pl script which will auto-generate the
> codestriker.pl file for you.
>
> Cheers,
> David
>
>
> Think green - keep it on the screen.
>
> This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.
>
>
>

------------------------------------------------------------------------------
EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
http://p.sf.net/sfu/ephox-dev2dev
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CodeStriker Configuration Issues with IIS 5.1

Hari Krishna Duvuri
David,

As mentioned below I have replaced the "croak" with "die" and executed but it throws the below error

-----------------------ERROR-----------------------

It looks like you don't have a C compiler and make utility installed.  Trying
to install dmake and the MinGW gcc compiler using the Perl Package Manager.
This may take a a few minutes...


It looks like the installation of dmake and MinGW has failed.  You will not be
able to run Makefile commands or compile C extension code.  Please check your
internet connection and your proxy settings!

Checking for  LWP::UserAgent (any)     ok: found v5.835
Checking for             CGI (v2.56)   ok: found v3.51
Checking for       Net::SMTP (any)     ok: found v2.31
Checking for MIME::QuotedPrint (v2.14)   ok: found v3.13
Checking for             DBI (v1.13)   ok: found v1.616
Checking for        Template (v2.07)        not found
Checking for  HTML::Entities (any)     ok: found v3.68
Checking for      File::Temp (any)     ok: found v0.22
Checking for        XML::RSS (v1.05)    ok: not found, optional
Checking for    Encode::Byte (any)     ok: found v2.04
Checking for Encode::Unicode (any)     ok: found v2.07
Checking for       DBD::ODBC (any)     ok: found v1.24


Codestriker requires some Perl modules which are either missing
from your system, or the version on your system is too old.
 Missing "Template"
   Minimum version required: 2.07

These can be installed by doing the following in PPM:

C:> ppm

C:> ppm
PPM> rep add theory http://theoryx5.uwinnipeg.ca/cgi-bin/ppmserver?urn:/PPMServer58
PPM> install (package-name)

*NOTE* The Template package name may not be "Template" but "Template-Toolkit"
when entering the commands above.

Go to http://theoryx5.uwinnipeg.ca/ppms if you have any installation problems.
Other Win32 ppm repositories are listed there.

The ActiveState default repository in PPM has almost all of the packages
required.

Best Regards,
Hari Krishna D


-----Original Message-----
From: David Sitsky [mailto:[hidden email]]
Sent: Tuesday, June 07, 2011 11:11 AM
To: Duvuri, Hari Krishna
Cc: [hidden email]
Subject: Re: [Codestriker-user] CodeStriker Configuration Issues with IIS 5.1

You really need to use Perl 5.8 or 5.10.  The Perl people changed the list of default packages installed.

You can still use 5.12, but edit the Codestriker.pm file and replace all instances of "croak" with "die".

On Tue, Jun 7, 2011 at 1:35 PM, Duvuri, Hari Krishna <[hidden email]> wrote:

> David,
>
> I am getting the following error when i run the "install.pl" file
> command prompt. I hope I am still missing some settings
>
> String found where operator expected at
> D:\codestriker/lib/Codestriker.pm line 5 69, near "croak "Failed to
> execute $system_line: $!\n""
>        (Do you need to predeclare croak?) syntax error at
> D:\codestriker/lib/Codestriker.pm line 569, near "croak "Failed to
> execute $system_line: $!\n""
> Compilation failed in require at
> D:\codestriker/lib/Codestriker/DB/DBI.pm line 1 4.
> BEGIN failed--compilation aborted at
> D:\codestriker/lib/Codestriker/DB/DBI.pm li ne 14.
> Compilation failed in require at
> D:\codestriker/lib/Codestriker/Model/User.pm li ne 14.
> BEGIN failed--compilation aborted at
> D:\codestriker/lib/Codestriker/Model/User.p
> m line 14.
> Compilation failed in require at D:\codestriker\bin\install.pl line 58.
> BEGIN failed--compilation aborted at D:\codestriker\bin\install.pl
> line 58.
>
> Best Regards,
> Hari Krishna D
>
> -----Original Message-----
> From: David Sitsky [mailto:[hidden email]]
> Sent: Tuesday, June 07, 2011 1:02 AM
> To: Duvuri, Hari Krishna
> Cc: [hidden email]
> Subject: Re: [Codestriker-user] CodeStriker Configuration Issues with
> IIS 5.1
>
>> As specified in section 2.5 I have configured and when I try to
>> browse
>
>> the http://localhost/codestriker/codestriker.pl and it throws and
>> error page couldn't be found. I further went and checked in
>> "D:\codestriker\bin" but I didn't find the "codestriker.pl" file.
>
> You need to run the install.pl script which will auto-generate the
> codestriker.pl file for you.
>
> Cheers,
> David
>
>
> Think green - keep it on the screen.
>
> This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.
>
>
>


Think green - keep it on the screen.

This e-mail and any attachment is for authorised use by the intended recipient(s) only. It may contain proprietary material, confidential information and/or be subject to legal privilege. It should not be copied, disclosed to, retained or used by, any other party. If you are not an intended recipient then please promptly delete this e-mail and any attachment and all copies and inform the sender. Thank you.



------------------------------------------------------------------------------
EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
http://p.sf.net/sfu/ephox-dev2dev
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Loading...