diff text shown as diff text

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

diff text shown as diff text

David Carson
I have a user who created his diff text using "cvs diff -uN" in various slightly different ways.  The results are always that Codestriker shows the diff text as if it did not know it was a valid diff -- just shows as a plain diff file.

The first time, he did "cvs diff -uN <dir>" and then he cd-ed to the <dir> and did it without arguments, etc.  I have looked at the diff and it certainly looks correct to me.  I have compared it to diffs of topics that display the diff correctly and cannot see any obvious differences.

How might I go about debugging this?  Maybe this is a known issue?

(David S., I could send you the diff directly, or perhaps I could sanitize it so that the proprietary issue is avoided.)

David

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: diff text shown as diff text

David Sitsky
Administrator
Please send the diff to me.  I'd ideally like to add it as a unit
test, so if you can sanitize it too, that would be good.

Cheers,
David

On Thu, Dec 4, 2008 at 7:57 AM, David Carson <[hidden email]> wrote:

> I have a user who created his diff text using "cvs diff -uN" in various
> slightly different ways.  The results are always that Codestriker shows the
> diff text as if it did not know it was a valid diff -- just shows as a plain
> diff file.
>
> The first time, he did "cvs diff -uN <dir>" and then he cd-ed to the <dir>
> and did it without arguments, etc.  I have looked at the diff and it
> certainly looks correct to me.  I have compared it to diffs of topics that
> display the diff correctly and cannot see any obvious differences.
>
> How might I go about debugging this?  Maybe this is a known issue?
>
> (David S., I could send you the diff directly, or perhaps I could sanitize
> it so that the proprietary issue is avoided.)
>
> David
>
> -------------------------------------------------------------------------
> This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
> Build the coolest Linux based applications with Moblin SDK & win great
> prizes
> Grand prize is a trip for two to an Open Source event anywhere in the world
> http://moblin-contest.org/redirect.php?banner_id=100&url=/
> _______________________________________________
> Codestriker-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/codestriker-user
>
>

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Codestriker-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/codestriker-user
Loading...